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Keyboard
Keys that Activate the File Menu and Button Commands and the Options Settings

Commands Keys 

File Menu and
Buttons 

Run Ctrl-R, Alt-F-R

Add F2, Alt-F-A

Remove F3, Alt-F-M

Save Ctrl-S, Alt-F-S

Close Ctrl-C, Alt-F-C

Options Menu 

Run App As... sub-menu

  Normal Shift-F1

  Minimized Shift-F2

  Maximized Shift-F3

  Normal w/o Focus Shift-F4

  Maximized w/o Focus Shift-F5

Action On Use... sub-menu

  Close Shift-F6

  Minimize Shift-F7

  Remain Shift-F8

Auto-Save On Close Ctrl-A, Alt-O-A

Help Menu 

Help F1, Alt-H-I

Help on Help Alt-H-H

About Alt-H-A



The Enter key can be used to launch an application, but only when the Run Line has 
the focus.

As with all Windows applications, the Tab key shifts focus from one object to the next 
in a specified order, but Runway is designed to keep the focus on the Run Line as 
much as possible. Most actions that produce a result (e.g. a Save, a Run, an Add, etc.)
returns the focus to the Run Line, where the action is.

See Tips, Quirks, and Miscellanea for reasons why you should avoid using Alt keys.



The File Menu And Button Commands
File Menu Commands and the Command Buttons are redundant to allow for 

user preference.

Run
Add
Remove
Save
Close



The Options Menu
Set your Options the way you like them and make sure you save them, either 
manually with SAVE or by enabling Auto-Save On Close.

Run App As...
Action On Use
Auto-Save On Close



Entering and Running an Application
Basic Instructions

Be sure to see Tips, Quirks, and Miscellanea for exceptions and problems with the 
procedure below.

The Procedure: 

    1. Make sure the desired options are set in the Options Menu. The Status Line 
indicates the current settings.

    2. Make sure the focus is on the Run Line (indicated by a blinking cursor). Use the 
Tab key or click on the Run Line with the mouse pointer if it doesn't already have the 
focus.

    3(a). If you want to run a stored application from the User's Application List,open 
the list by clicking the Down arrow button on the right end of the Run Line and click 
on the desired application, OR open the list by pressing either the F4 key or by 
pressing the Alt and Down (a directional key) keys simultaneously, and then use the 
directional keys to scroll through the selections. Note that the currently hilited 
application in the list appears on the Run Line. Or for even easier access, simply 
pressing the Down directional key will pop the top item in the User's Application List 
onto the Run Line, and repeated pressing of the Down key will pop up the application 
immediately below the one on the Run Line. Accessing the User's Application List in 
this manner will NOT cause the list to drop down, however.

    3(b). If you want to run an application not on the User's Application List, type in the 
valid filename for any Windows executable file. (Runway will run DOS applications 
too, but the use of PIF files is highly recommended. See your Windows manual for 
information on running DOS applications with PIF files.) If the application is not in a 
directory on your DOS path, you must enter a full path also.

    4. With the desired application on the Run Line, run it by ONE of these methods:

      A. Click on the Run button.
      B. Click the File menu and then click Run.
      C. Press the Ctrl-R keys.
      D. Press the Alt-F-R keys.
      E. Press the ENTER key (be sure the Run Line has the focus first).

That's it! Your application should now be running as desired.



Adding and Removing and the User's    Application List
Basic Instructions

The user may store up to 50 applications in a special User's Application List.

General Notes: Remember that additions and removals are temporary until 
saved via the Save Command or by the Auto-Save On Close option. Also, be aware 
that attempting an Add or a Remove when no application name is on the Run Line 
results in an error message.

    To Add an Application: 

    1. Make sure that the Run Line has the focus and type in the executable filename of
the application to be stored. If the application is not in a directory on your DOS path, 
you must type in a full path also.

    2. Add the application by ONE of these    methods:

        A. Click the Add button.
        B. Click the File Menu, then click Add.
        C. Press the F2 key.
        D. Press the Alt-F-A keys.

    3. Voilá!

    To Remove an Application: 

    1. Bring the desired application up onto the Run Line (see Entering and Running An 
Application for instructions on how to do this).

    2. Remove the application by ONE of these methods:

        A. Click the Remove button.
        B. Click the File Menu, and click Remove.
        C. Press the F3 key.
        D. Press the Alt-F-M keys.

    3. Voilá!



Closing
Closing Runway 1.2b

Runway may be closed in a variety of ways:

    1. Clicking the Close button
    2. Clicking the File Menu, then Close.
    3. Pressing the Ctrl-C keys.
    4. Pressing the Alt-F-C keys.
    5. Choosing Close from the window Control Bar.
    6. Using Windows Task Manager to "End Task."

DO NOT USE Task Manager (#6) to close Runway or ANY application written in Visual 
Basic! (See Tips, Quirks, and Miscellanea for details.)

The remaining methods (#1-5) will all close Runway in an efficient manner and allow 
Runway to prompt the user to save changes to the User's Application List, if any were
made, or to perform an Auto-Save On Close, if that option is set to ON.



Tips, Quirks, And Miscellanea
For Your Information...

* FileBoy's Runway 1.2b is part of a suite of Windows applications (all written in Visual
Basic). All applications in the FileBoy clan use the same initialization file, FILEBOY.INI, 
to store their start-up data, and each will automatically add it's data to that file 
without user intervention.    FILEBOY.INI must be located in your Windows directory, 
however, or none of the FileBoy aplications will be able to find it. (This may not be the
case with future versions.)

* Tip: Always save additions and removals to the User's Application List manually as 
soon as you make them instead of depending on the Auto-Save On Close to do it for 
you. This will avoid the short delay (3-5 seconds) when Runway closes with the Auto-
Save On Close option ON. Future versions of Runway will be able to check whether or 
not the user has made ANY changes to anything and will simply skip the Auto-Save 
even if it's ON.

* Tip: The combination of "Run App As Minimized without Focus" and "Action On Use: 
Remain" is the best for setting up a number of applications in one go, but setting 
Runway's options to "Run App As: Normal" with "Action On Use: Minimize" is probably
the most convenient and efficient for the majority of users.

* There are a couple of quirks to keep in mind concerning the "Run App As..." options 
in the Options Menu:

Minor Quirk: A few Windows applications are uncooperative when it comes to 
following their start-up commands. Some will not relinquish focus, others may not 
have to capability to run Maximized, etc, etc. This is not a flaw in Runway, but a 
matter of an individual application's design. Que séra, séra.

Minor Quirk: There is a bug in Visual Basic that causes a combo box (i.e. the Run 
Line/User's Application List) to ignore the first keystroke sent to it immediately after 
an Alt key has been pressed. For this reason, you should either use the mouse to 
manipulate Runway's commands or make use of the various shortcut keys, rather 
than access the commands by using the "Alt-?" type of menu access.

MAJOR QUIRK: About using the "End Task" in Windows Task Manager: DON'T DO IT!   
This is the result of a bug in either Visual Basic or Windows itself which, when a Visual
Basic application is closed in this manner, results in the closing of the VB app 
WITHOUT removing it from memory. Hence, you could be looking at "Out of Memory" 
messages that could have been easily avoided.



Run
The RUN Command

    Keyboard Access: Ctrl-R, Alt-F-R

Activating the Run File Menu item or Button will cause Runway to attempt to launch 
the application currently on the Run Line.    If there is no application on the Run Line, 
an error message is generated.

The Run command attempts to launch an application according to the current 
settings in the "Run App As..." section in the Options Menu (see Tips, Quirks, and 
Miscellanea for exceptions) and causes Runway to react in the manner set in the 
"Action On Use..." section of the Options Menu.

See Entering and Running an Application.

 



Add
The ADD Command

    Keyboard Access: F2, Alt-F-A

The ADD File Menu item or Button will place the application currently on the Run Line 
into the User's Application List.    Added applications are always placed at the bottom 
of the list.

Applications placed in the User's Application List are NOT saved when you close 
Runway UNLESS you have the Auto-Save On Close option enabled, or you perform a 
manual save with the Save command.

See The REMOVE Command
        Adding and Removing and the User's Application List
        Tips, Quirks, and Miscellanea



Remove
The REMOVE Command

    Keyboard Access: F3, Alt-F-M

Use the REMOVE File Menu item or Button to delete an application from the User's 
Application List.    The Remove command only operates on the application currently 
on the Run Line. Trying to delete an application on the Run Line which hasn't been 
previously added to the list with the ADD command will result in an error message.

Although the Remove command deletes both temporary and stored applications from
the list, it does not make these changes permanent. To do so, you must either have 
the Auto-Save On Close enabled or perform a manual save with the Save command 
before closing Runway.

See Adding and Removing and the User's Application List
        Tips, Quirks, and Miscellanea



Save
The SAVE Command

    Keyboard Access: Ctrl-S, Alt-F-S

Activating the SAVE File Menu item or Button causes Runway to store all current 
settings in the Options Menu AND the applications in the User's Application List to its 
initialization file, FILEBOY.INI. Anytime you perform an Add or a Remove, or make 
changes in the Options Menu items, your changes are temporary unless you perform 
a manual save with the Save command or unless you have the Auto-Save On Close 
option enabled.

See Adding and Removing and the User's Application List
        Tips, Quirks, and Miscellanea



Close
The CLOSE Command

    Keyboard Access: Ctrl-C, Alt-F-C

The Close File Menu item or Button causes Runway to shut down and unload itself 
from memory. If the Auto-Save On Close option in the Options Menu is enabled, all 
current settings in the Options Menu and all current applications in the User's 
Application List are stored in the FILEBOY.INI file at this time.

If the Auto-Save On Close option is not enabled and changes have been made to the 
User's Application List, the user will be prompted to Save or discard the changes. 
Only changes in the User's Application List are tracked in this manner. The user is 
responsible for remembering to save or discard changes made to the items in the 
Options Menu.

See Closing
        Tips, Quirks, and Miscellanea



Auto-Save On Close
The "Auto-Save On Close" Option

Be sure to see Tips, Quirks, and Miscellanea for exceptions and problems with the 
option settings below.

The Auto-Save On Close option is a toggle: it is either ON or OFF. If it is ON, when 
Runway is closed by any method it will save the current option settings (including its 
own Auto-Save On Close setting: ON) and the current applications in the User's 
Application List into the FILEBOY.INI file (located in your Windows directory).

The current setting for Auto-Save On Close is indicated by a checkmark in the 
Options Menu and by the Status Line readout.

Note: if Auto-Save On Close has saved itself as ON, simply turning it OFF will not un-
save it, and the next time you run Runway it will again be ON. To remove the ON 
setting, you must perform a manual Save while Auto-Save On Close is turned OFF.



Run App As...
The "Run App As..." Options

Be sure to see Tips, Quirks, and Miscellanea for exceptions and problems with the 
option settings below.

Run App As...
 
The "Run App As..." menu item contains a sub-menu of five options which determine 
how the selected application will run. The options are mutually exclusive: selecting 
one deselects the others. The current selection is indicated by a checkmark in the 
"Run App As..." sub-menu and by the Status Line readout. The options are as follows:

    Run App As Normal 
        Keyboard: Shift-F1

This option causes the selected application to run in the normal manner--neither 
Minimized or Maximized--and gives it the focus in Windows.

    Run App As Minimized 
        Keyboard: Shift-F2

This option loads the selected application as an icon at the bottom of the desktop and
gives it the focus in Windows.

    Run App As Maximized 
        Keyboard: Shift-F3

This option runs the selected application "full screen," obscuring the entire desktop. 
The application receives the focus in Windows by default.

    Run App As Normal without Focus 
        Keyboard: Shift-F4

This option is similar to the Run App As Normal option above, only the selected 
application does not have the focus (i.e. is inactive).

    Run App As Minimized without Focus 
        Keyboard: Shift-F5

This option is similar to the Run App As Minimized option above, only the icon does 
not have the focus in Windows. This is perhaps the most useful of these options if you
want to activate several applications one after the other.



Action On Use
The "Action On Use..." Options

Be sure to see Tips, Quirks, and Miscellanea for exceptions and problems with the 
option settings below.

    Action On Use... 

The "Action On Use..." menu item contains a sub-menu of options which determine 
how Runway will react at the time an application is run. These options are mutually 
exclusive: selecting one deselects the others. The current selection is indicated by a 
checkmark in the "Action On Use..." sub-menu and by the Status Line readout. The 
options are as follows:

    Action On Use: Close 
        Keyboard: Shift-F6

Setting this option causes Runway to close itself and unload from memory at the time
that the selected application is run.

    Action On Use: Minimize 
        Keyboard: Shift-F7

Setting this option forces Runway to the bottom of the desktop as an icon when the 
selected application is run, thereby allowing easy access if you want to run other 
applications.

    Action On Use: Remain 
        Keyboard: Shift-F8

When this option is selected, Runway takes no action after running an application and
remains on the desktop just as it was before. Whether or not Runway is visible or 
keeps the focus in Windows depends on the "Run App As..." option settings.

 



FileBoy's Runway 1.2b
What's at the Heart of Things.

FileBoy's Runway 1.2b is both easily configured and simple to operate. It is only 
necessary to be aware of the five basic elements that compose Runway:

      File Menu and Button Commands:
All immediate actions are initiated by these commands, which are identical as items 
in the File Menu and as Buttons on the Runway interface. All of them have Keyboard 
Shortcut Keys associated with them, so you may use whichever means is most 
comfortable for you.

      Options Menu Settings:
These define the way Runway does everything from start-up to close, and are stored 
in the initialization file, FILEBOY.INI, in your Windows directory. If this file does not 
exist, it will be created by Runway.

      The Run Line:
This is the long white input line that crosses the Runway interface. It is similar to the 
DOS command line in that it is where the user enters the paths and filenames of the 
applications he/she runs.

      The User's Application List:
This is a list (actually, a menu that drops down from the Run Line) where the user can
store up to 25 of his/her favorite and most-used applications for even quicker access.

      The Status Line:
At the bottom edge of the Runway interface there is a Status Line that constantly 
keeps the user inform as to the current settings in the Options Menu: "Run App As...";
"Action On Use..."; and "Auto-Save On Close."




